A structural change to an API endpoint was causing the client application to search for data that was no longer present. This has been remediated.
Posted Oct 28, 2025 - 14:59 EDT
Monitoring
A fix has been deployed and connections are now restored. We are proceeding with root cause analysis.
Posted Oct 28, 2025 - 14:33 EDT
Identified
We have identified the cause of the issue, and are working on remediation methods. We will provide an update within the next 30 minutes.
Posted Oct 28, 2025 - 14:10 EDT
Investigating
We are actively investigating an issue where certain users are unable to connect via the client application. We will send and update within 30 minutes.
Posted Oct 28, 2025 - 13:57 EDT
This incident affected: https://dashboard.dispel.io (Applications (iOS, macOS, Windows)).