Stabilizing workarounds have been implemented across all environments. Our teams will be monitoring the service status of our dependency technologies, but our environments should not be experiencing any further disruptions.
Posted Oct 20, 2025 - 21:50 EDT
Update
Although our service dependencies are still experiencing degraded performance, workarounds have been identified and implemented across all environments.
Dashboards should be operational, but may experience periodically degraded performance.
Our teams are still working on monitoring our service dependency statuses, as well as implementing additional resiliency factors.
Posted Oct 20, 2025 - 20:35 EDT
Update
We are continuing to monitor all environments and the issues in them. Although AWS is now reporting resolved, our other AWS-based dependencies are still reporting degraded service, which in turn is causing degraded service of the Dispel platform.
Posted Oct 20, 2025 - 19:46 EDT
Update
AWS has posted service status as Resolved. The Dispel team is actively undergoing service recovery actions to ensure full recovery of the platform.
Posted Oct 20, 2025 - 19:15 EDT
Identified
Due to the Amazon AWS outage, there is currently an issue with dashboards when trying to sign in or load in data.
Existing connections from Virtual Desktops and Applications should remain unaffected.