Browser Connect Connections Might be Failing

Incident Report for Dispel

Monitoring

A fix has been implemented, and we are currently monitoring connections for service restoration.
Posted Jul 02, 2026 - 21:44 EDT

Identified

We see Browser Connect connections failing to establish in some of our environments. Teams have identified the source of the issue and are working on remediation.
Posted Jul 02, 2026 - 20:41 EDT
This incident affects: Dashboard.