Notice: Bastion Connectivity Issues

Incident Report for Dispel

Resolved

The component is stable and a longer term update is being worked on for next release.
Posted Dec 17, 2024 - 23:15 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 17, 2024 - 23:15 EST

Investigating

We are aware of an issue affecting browser-based connections to Bastion. This is a performance issue with Microsoft's Bastion product, and has been reported to Microsoft. We are actively working towards a resolution for stability of our customers in the meantime. If you are experiencing this issue or need alternative connection options, please contact us at support@dispel.io.
Posted Dec 17, 2024 - 18:45 EST
This incident affected: https://dashboard.dispel.io (Virtual Desktops).