Dashboard is operational and stable. Please reach out to your Dispel support lines if you experience any further issues.
Posted Jun 16, 2026 - 13:58 EDT
Monitoring
A fix has been implemented. If you are still experiencing issues, please clear your browser cache or attempt in an incognito browser. Our teams are monitoring for full resolution and restoration.
Posted Jun 16, 2026 - 13:03 EDT
Update
We are continuing to investigate this issue.
Posted Jun 16, 2026 - 12:05 EDT
Investigating
We are aware that the dashboard.dispel.io platform is failing to load for some users. Teams are actively investigating this issue.
Posted Jun 16, 2026 - 12:05 EDT
This incident affected: https://dashboard.dispel.io (Dashboard).