SSO failures

Incident Report for Dispel

Postmortem

Incident Report

At 2:16 AM Tuesday, Coordinated Universal Time (UTC), we received notifications of SSO failures.

At 2:38 AM UTC we identified the cause. A worker queue processing job requests encountered a combination of a failed job and a high level of requests. While the failed job was clearing, the volume of requests created a processing delay. This was isolated to a single customer’s job queue and did not impact any other customers.

At 2:42 UTC we cleared the failed job and resumed request processing. We confirmed logins were restored for the customer, and monitored to ensure the queue completed all outstanding tasks.

We apologize for the inconvenience. Our team is reviewing working task clearing at high volume moments to mitigate future events such as this.

Posted Jun 23, 2025 - 23:11 EDT

Resolved

This incident has been resolved. The worker queue has been restored and all jobs are processing normally.
Posted Jun 23, 2025 - 22:59 EDT

Monitoring

A fix has been implemented and we are monitoring the environment.
Posted Jun 23, 2025 - 22:50 EDT

Identified

A build up of requests in one customer's environment has been identified as the cause of localized SSO errors. No other customers are impacted.
Posted Jun 23, 2025 - 22:49 EDT

Investigating

We are aware that SSO may not be working for some domains in the APAC region. We are investigating the issue now.
Posted Jun 23, 2025 - 22:36 EDT
This incident affected: https://dashboard.dispel.io (Dashboard).