Azure Service Impacting Virtual Desktops

Incident Report for Dispel

Resolved

Azure has reported restoration of services and is monitoring recovery. Virtual desktop capabilities should be fully restored.
Posted Apr 24, 2026 - 20:41 EDT

Update

We are continuing to monitor Azure's updates to restore data center functionality, and therefore virtual desktop functionality.
Posted Apr 24, 2026 - 16:44 EDT

Monitoring

We are monitoring the situation with Azure and will provide updates of service restoration as soon as possible.
Posted Apr 24, 2026 - 15:26 EDT

Investigating

Microsoft Azure is currently experiencing some failures and delays for resources in the East US Region. This may impact the availability of virtual desktops hosted in the impacted US datacenters.

For more information, please refer to Azure's status page at https://azure.status.microsoft/en-us/status
Posted Apr 24, 2026 - 15:25 EDT
This incident affected: Virtual Desktops.